xqzz.net
当前位置:首页 >> linux下安装rpm缺少库的问题. >>

linux下安装rpm缺少库的问题.

你这几个不是针对你当前系统的包吧? 这几个依赖都算是是基本库,应该你的系统自带了。你这可能是版本不对应导致 so 后面的那个接口版本号不一致。 rpm -q 只是搜索他自己的数据库,这个数据库只有已经安装的软件书记。找不到的依赖,你再怎么用...

很简单啊 rpm -qa|grep lib*.so* 如果下面列出你要的就表示装了 或者是你安装新的rpm包时用rpm -Uvh *.rpm

下载安装埃。。不会源代码安装就用yum install去安装 很方便的

你的命令没有问题。 rpm-5.1.6.tar.gz不是rpm包,是一个gz的压缩包,用tar -xzvf rpm-5.1.6.tar.gz是可以解压成功的。 如果你要装rpm包,应该是 rpm -ivh 包名,或者你那个rpm-5.1.6.tar.gz原本是rpm包,后来被重命名了,你用rpm -ivh rpm-5.1.6....

1.加上 --nodeps,意思不考虑依赖 2.更狠的--force,强制安装 你可以在这两个之前试试--aid自己解决依赖

RPM是RPM Package Manager(RPM软件包管理器)的缩写,是已编译的二进制程序包,执行如下命令即可安装。 rpm -ivh 要安装的rpm文件包 以安装vsftd程序包为例,执行效果如下图所示:

你的命令没有问题。 rpm-5.1.6.tar.gz不是rpm包,是一个gz的压缩包,用tar -xzvf rpm-5.1.6.tar.gz是可以解压成功的。 如果你要装rpm包,应该是 rpm -ivh 包名,或者你那个rpm-5.1.6.tar.gz原本是rpm包,后来被重命名了,你用rpm -ivh rpm-5.1.6....

libtcl8.5.so在tcl包里 你用yum装,会自动安装依赖包: yum install expect

安装盘里面找,如果找不到,证明你装的数据库不支持你用的这个 Linux 。 不过如果你要使用的 mysql ,安装盘里面已经又了,安装系统时选上数据库支持部分的 mysql 支持就行了。 还有, RH 的东西不花钱不能用在线软件库,如果不想花钱,不建议用...

不要装这个版本的,换成系统安装盘里的安装包

网站首页 | 网站地图
All rights reserved Powered by www.xqzz.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com