xqzz.net
当前位置:首页 >> linux 安装 rpm,缺少依赖包,怎么解决 >>

linux 安装 rpm,缺少依赖包,怎么解决

1.加上 --nodeps,意思不考虑依赖 2.更狠的--force,强制安装 你可以在这两个之前试试--aid自己解决依赖

表示nsmbd这个包要依靠或调用libc.so.6,libpam.so.0等等这些的函数库或其他类似数据。所以要解决就必须安装这4个东西。 如果你是RH的,就#YUM INSTALL GLIBC—2。4。。。括号里面的那个名称 依次装完就可以装nsmbd。 如果ubuntu或dbian 就#apt-...

你这几个不是针对你当前系统的包吧? 这几个依赖都算是是基本库,应该你的系统自带了。你这可能是版本不对应导致 so 后面的那个接口版本号不一致。 rpm -q 只是搜索他自己的数据库,这个数据库只有已经安装的软件书记。找不到的依赖,你再怎么用...

表示nsmbd这个包要依靠或调用libc.so.6,libpam.so.0等等这些的函数库或其他类似数据。所以要解决就必须安装这4个东西。 如果你是RH的,就#YUM INSTALL GLIBC—2。4。。。括号里面的那个名称 依次装完就可以装nsmbd。 如果ubuntu或dbian 就#apt-...

哪有自己依赖自己的rpm包的呢,截图上面的提示信息的意思是needed by,是某某rpm包“被......依赖”的意思,所以“needed by”前面的名字才是安装时依赖的软件包,这个软件包依赖的应该是libcom_err-devel和pkgconfig(com_err)这两个软件。

先装下面缺少的依赖包 不如用yum装,自动安装依赖包

yum list |grep 软件名称 看下有没有想要的低版本,有的话yum安装跟上版本号,如果没有那么就需要搜索下源码下载编译安装; 安装devel版本需要安装非devel yum install pcre pcre-devel

glibc = 2.5-42 依赖这个版本 你安装的却是 glibc-headers-2.5-24 42和24不同。。

先安装mailcap这个包 rpm -ivh mailcap-2.1.23(大概是这个名字,tab键自动补全就可以) 然后再安装httpd 不过也有可能还有其他的依赖性问题,建议还是使用yum

网站首页 | 网站地图
All rights reserved Powered by www.xqzz.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com